Obecná diskuze o vývojiUbuntu + Eclipse + nefunkční AVD

Moderátor: mArtinko5MB

Odpovědět

Autor tohoto vlákna
radimdostal
Nové Androidě
Příspěvky: 7
Registrován: čtv 28. lis 2013 20:59:38
Reputace: 0
Typ mobilu / ROM: HTC Desire S

Ubuntu + Eclipse + nefunkční AVD

Příspěvek od radimdostal » sob 03. srp 2019 8:07:28

Ahoj,
chci začít vyvíjet aplikace pro Android na Ubuntu 18.4. v Eclipse pomocí ADT pluginu (nepište, že mám přejít na Android Studio, jsem na Eclipse zvyklý, používám jej i na jiné věci :-), navíc mám pocit, že můj problém přímo s Eclipse nesouvisí). Eclipse s plginem se jeví jako funkční, mám stažené Android SDK pro 3 API, které chci v různých projektech používat. Naimportoval jsem si i nějaký projekt, který jsem dříve dělal na jiném PC. Vše se jeví v pořádku do okamžiku, kdy chci spustit svou aplikaci na virtuálním zařízení. Zkusil jsem vytvořit už několik zařízení přes Android Virtual Device Manager a vždy to dopadlo stejně. Když to zařízení spustím, tak se otevře okno emulátoru, je černé, nebo na černém pozadí je nápis Android, jako že se systém spouští. Ale to je vše, nic dalšího se neděje. Když chci na něm spustit z Eclipse svou aplikaci, nestane se v zařízení nic. V konzoli Eclipse je

[2019-08-03 08:59:17 - Debts] Installation error: Unknown failure
[2019-08-03 08:59:17 - Debts] Please check logcat output for more details.
[2019-08-03 08:59:17 - Debts] Launch canceled!

Když se podívám do logcatu, krom spousty hlášek na nižší úrovni než error jsou tam pořád dokola se opakující chybové hlášky:

08-03 08:57:09.805: E/Zygote(2384): setreuid() failed. errno: 17
08-03 08:57:10.554: E/BatteryService(2391): usbOnlinePath not found
08-03 08:57:10.554: E/BatteryService(2391): batteryVoltagePath not found
08-03 08:57:10.554: E/BatteryService(2391): batteryTemperaturePath not found
08-03 08:57:10.564: E/FramebufferNativeWindow(2391): couldn't open framebuffer HAL (No such file or directory)
08-03 08:57:10.564: E/SurfaceFlinger(2391): Couldn't open /sys/power/wait_for_fb_sleep or /sys/power/wait_for_fb_wake

Řek bych (jen domněnka), že hlášky z logu s mým problémem nijak nesouvisí.

Vím o jiném PC se stejným Ubuntu i Eclipsem, kde vše funguje jak má. Jako by mi něco scházelo (knihovna, utilita, ...). Nenapadá vás, čím to může být, nebo kam se podívat, abych to zjistil?

Radim




Uživatelský avatar

policak
Robot
Příspěvky: 1121
Registrován: pát 21. čer 2013 20:43:28
Reputace: 57
Typ mobilu / ROM: Vernee Apollo X

Re: Ubuntu + Eclipse + nefunkční AVD

Příspěvek od policak » sob 03. srp 2019 9:04:41

Zeptám se úplně blbě, protože o tomto nevím ani zbla, jen mě zaujal ten log, co pořád opakuje že něco nenašlo nějakou cestu...kolik disků je na tom PC? Není problém v tom, že Eclipse hledá nějakou natvrdo nastavenou cestu, která tady nefunguje?
Podpis...to jako můj? Nebo čí? Radši to nechám volný.

Uživatelský avatar

Crusty
Robot
Příspěvky: 870
Registrován: ned 19. črc 2009 17:30:40
Reputace: 21
Typ mobilu / ROM: HTC Evo 3D
Bydliště: Praha
Kontaktovat uživatele:

Re: Ubuntu + Eclipse + nefunkční AVD

Příspěvek od Crusty » sob 03. srp 2019 10:07:05

zkus radeji Android Studio, to je podporovano


Autor tohoto vlákna
radimdostal
Nové Androidě
Příspěvky: 7
Registrován: čtv 28. lis 2013 20:59:38
Reputace: 0
Typ mobilu / ROM: HTC Desire S

Re: Ubuntu + Eclipse + nefunkční AVD

Příspěvek od radimdostal » sob 03. srp 2019 11:25:09

policak píše:
sob 03. srp 2019 9:04:41
Zeptám se úplně blbě, protože o tomto nevím ani zbla, jen mě zaujal ten log, co pořád opakuje že něco nenašlo nějakou cestu...kolik disků je na tom PC? Není problém v tom, že Eclipse hledá nějakou natvrdo nastavenou cestu, která tady nefunguje?
Je tam jeden disk, resp. 2 logické (jeden pro Linux, druhý pro Win) na jednom fyzickém disku. Myslím si ale, že ty cesty uvedené v chybách v logu budou cesty na tom virtuálním zařízení. Ne na mém disku. Pravda je, že na svém PC v adresáři /sys/power/ ten soubor nemám.

Uživatelský avatar

policak
Robot
Příspěvky: 1121
Registrován: pát 21. čer 2013 20:43:28
Reputace: 57
Typ mobilu / ROM: Vernee Apollo X

Re: Ubuntu + Eclipse + nefunkční AVD

Příspěvek od policak » sob 03. srp 2019 13:01:12

A v tom PC, kde to jede, jsou taky dva logické oddíly, nebo jen jeden?
Podpis...to jako můj? Nebo čí? Radši to nechám volný.



Autor tohoto vlákna
radimdostal
Nové Androidě
Příspěvky: 7
Registrován: čtv 28. lis 2013 20:59:38
Reputace: 0
Typ mobilu / ROM: HTC Desire S

Re: Ubuntu + Eclipse + nefunkční AVD

Příspěvek od radimdostal » ned 04. srp 2019 8:47:16

Disky jsou stejné, tedy dva logické.

Uživatelský avatar

LivArt
Terminátor
Příspěvky: 22285
Registrován: čtv 14. črc 2011 9:11:01
Reputace: 247
Typ mobilu / ROM: Xiaomi MI5 HavocOS
Mobil 2 / ROM: SGS4 + SGS6
Twitter: https://twitter.com/CZmisak
Tablet: SGTab4
Bydliště: In the end of the infinite loop.
Kontaktovat uživatele:

Re: Ubuntu + Eclipse + nefunkční AVD

Příspěvek od LivArt » ned 04. srp 2019 20:31:07

Ten logcat máš před tím errorem, musíš se koukat až po něm (error je 8.59, logcat 8.57).
lenovo - Je to ještě mnohem horší, než to vypadá.
Zpomalený nebo sekající se telefon - jak postovat
Nejobsáhlejší Doctor Who CZ & SK Fanweb | Sleduj mě na #twitteru.
Soukromé zprávy mi pište, pokud máte nějaký konkrétní dotaz na mě. Na ostatní dotazy je tu fórum.


Autor tohoto vlákna
radimdostal
Nové Androidě
Příspěvky: 7
Registrován: čtv 28. lis 2013 20:59:38
Reputace: 0
Typ mobilu / ROM: HTC Desire S

Re: Ubuntu + Eclipse + nefunkční AVD

Příspěvek od radimdostal » stř 07. srp 2019 15:28:02

To proto, že jsem emulátor pustil o chvíli dříve než jsem se pokusil spustit samotnou aplikaci. Tohle byla 1. hláška po spuštění a jak jsem psal, neustále se po nějaké chvíli hlášky opakují. Takže stejně to vypadalo i při spuštění aplikace.

Uživatelský avatar

|Mio|
Robot
Příspěvky: 870
Registrován: ned 15. črc 2012 9:13:49
Reputace: 13
Typ mobilu / ROM: Ulefone Power 3
Mobil 2 / ROM: iNew U3 + Power 2

Re: Ubuntu + Eclipse + nefunkční AVD

Příspěvek od |Mio| » pát 09. srp 2019 23:06:41

Nelišej se ty mašiny procesorem / platformou ?


Autor tohoto vlákna
radimdostal
Nové Androidě
Příspěvky: 7
Registrován: čtv 28. lis 2013 20:59:38
Reputace: 0
Typ mobilu / ROM: HTC Desire S

Re: Ubuntu + Eclipse + nefunkční AVD

Příspěvek od radimdostal » úte 27. srp 2019 20:45:57

Platforma je stejná. Procesor je Intel (fungující stroj) vs. AMD (nefungující), ale v tom bych asi příčinu nehledal.
Nakonec jsme to vzdal, a nainstaloval AndroidStudio. V něm to funguje na obou PC.

Děkuji všem zúčastněným za ochotu.

Odpovědět

Zpět na „Obecná diskuze o vývoji“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 1 host