Obecná diskuze o vývojiJaké SDK použít pro vývoj všech verzí Android?

Moderátor: mArtinko5MB

Odpovědět

Autor tohoto vlákna
unknow
Nové Androidě
Příspěvky: 3
Registrován: ned 08. bře 2020 10:32:20
Reputace: 0

Jaké SDK použít pro vývoj všech verzí Android?

Příspěvek od unknow » úte 10. bře 2020 18:36:59

Vážená komunito,

jakou verzi SDK je nejlepší použít, pokud bych chtěl vyvíjet aplikace pro všechny verze Android, respektive od verze 4.4?

Momentálně mám nainstalované Android 9 (API 28) a SDK Platform-tools rev. 28.0.1.
Když si nainstaluje všechny dostupné API a SDK a vytvořím v nich aplikaci, bude chodit i na starších Androidech zpětně?

Proč se ptám? Jedna z mých aplikací mi na Android 9.0 Pie ukázala hlášku, že se jedná o aplicai pro starší verze Androidů a nemusí tak fungovat správně. Rád bych se této hlášky zbavil.

Děkuji.





xanthor
Kyborg
Příspěvky: 5160
Registrován: čtv 21. říj 2010 14:38:18
Reputace: 83
Typ mobilu / ROM: Samsung Galaxy S7 [SM-G930F]
Mobil 2 / ROM: Xiaomi Redmi Note 3 Pro 2/16 [kate]
Tablet: Samsung Galaxy Tab A 10.1 2016 [SM-T580]
Tablet 2 / ROM: Alcatel OneTouch Pixi 3 (10)
Rom: S7: stock, kate: NOS

Re: Jaké SDK použít pro vývoj všech verzí Android?

Příspěvek od xanthor » úte 10. bře 2020 19:11:23

minsdk - nejstarší podporovaná verze Androidu (pro 4.4 je to 19)
compilesdk, targetsdk - co nejvyšší, nejnovější verze Androidu, o které aplikace "ví" (pro kterou byla napsána a připravena a s kterou je plně kompatibilní) - aktuálně 29 pro Android 10
Moje otevírací hodiny - otevírací hodiny ve Vašem telefonu

Odpovědět

Zpět na „Obecná diskuze o vývoji“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 1 host